Is your web site running PHP 5.6 still?

If so, you are not alone. By many estimates, over half of all WordPress-based web sites still run on PHP 5.x. As of December 31, 2018, security updates will no longer be provided for PHP 5.6. It’s important to know what version your web site is running on so that you can take the steps to update it.

In the best case scenario, your web hosting environment supports multiple versions of PHP and if your web site is on a platform like WordPress and everything is up to date, upgrading to PHP 7.x can sometimes be as easy as a click of a button. However, like many things in technology. It’s seldom that simple. Some web servers do not support multiple versions of PHP so in order to upgrade, you need to move to a newer server. Even if your server support PHP 7.x, your web site may not. Many times when you update PHP, the site will generate an error or not display correctly. This is often due to a plugin or some code in the site that needs to be fixed or updated in order to support PHP 7.x.

There is a great article online at www.searchenginejournal.com/wordpress-php/277067/ which goes in to more detail on why it is important to update your site’s PHP version, especially as time goes on.